Divinity Banner
Previous Thread
Next Thread
Print Thread
Awful Slowdown #225074
03/05/04 09:39 AM
03/05/04 09:39 AM
Joined: May 2004
Posts: 6
C
Case Offline OP
stranger
Case  Offline OP
stranger
C

Joined: May 2004
Posts: 6
Damn! - Movement Slowdown and glitchy screen scroll. Why? -
Brand New PC - 3GHz - 512 RAM
Radeon 9200 128MB Video Card. Latest Drivers.

Installed Patch. No Difference.
Tried Running Game at pitiful resolutions - No Difference. Well okay, it runs as bad, just looks worse.... :S

Anyone else out there having their Beyond Divinity Experience ruined like this?


Case.

Re: Awful Slowdown [Re: Case] #225075
03/05/04 09:55 AM
03/05/04 09:55 AM
Joined: Mar 2003
Posts: 26,006
Canada
Raze Offline

veteran
Raze  Offline

veteran

Joined: Mar 2003
Posts: 26,006
Canada
Anyone else out there having their Beyond Divinity Experience ruined like this?

Unfortunately, yes. A couple other people have run into this kind of problem.

Dreadful lock ups in game

Re: Awful Slowdown [Re: Case] #225076
03/05/04 05:23 PM
03/05/04 05:23 PM
Joined: May 2004
Posts: 3
F
FaithlessFemme Offline
stranger
FaithlessFemme  Offline
stranger
F

Joined: May 2004
Posts: 3
I had no problems playing DivDiv, but BeyDiv seems to install and play fine, except for the fact that it seems like its s-l-o-w-e-d WAY down. If I could somehow just TURN-UP the game speed maybe a notch or two, it would be PERFECT.

Is there any way to adjust the options, maybe in an .ini file somewhere to where I can just speed the entirety of the game up? Or maybe turning on/off a DirectX option somewhere? Even when running, my characters just inch along at a snails pace, and when I go to fight one single baddie, it takes forever and a day!

So - any help at all regarding this would be appreciated. And YES I have updated drivers, and surpass the minimum specifications for the game. On a side note, I installed this game on my D:\ drive (rather than C:\) because I have a lot more storage space on D. Is this game known to lag if its not installed into the DEFAULT directory on C:\?

Does anyone know if this game seems to play better on Windows XP Home vs. Professional edition? I may have the option to upgrade from XP Home to Pro soon, and wanna know if this would be a good idea, game-wise.

Thanks!

Re: Awful Slowdown [Re: FaithlessFemme] #225077
03/05/04 05:55 PM
03/05/04 05:55 PM
Joined: May 2004
Posts: 6
C
Case Offline OP
stranger
Case  Offline OP
stranger
C

Joined: May 2004
Posts: 6
Hi FaithlessFemme.

Yep. Exactly what I am seeing. DivDiv worked okay. This game plays just like the characters are running / fighting through glue.

I have now tried changing video cards:
OUT -> Radeon 9200.
IN --> GeFORCE FX 5600.

Up to date drivers checked. Still no improvement. Same symptoms.

Really would like an answer as the game looks great. Just plays like a dog.

IS ANYONE AT LARIAN LISTENING? -
I paid my money. So now I want to play the game!

Re: Awful Slowdown [Re: Case] #225078
03/05/04 07:23 PM
03/05/04 07:23 PM
Joined: Mar 2003
Posts: 579
Belgium
Tovi Offline
addict
Tovi  Offline
addict

Joined: Mar 2003
Posts: 579
Belgium
What resolution do you guys play in? Try lowering the resolution. That always helps.


Tovi May Raan refresh you!
Re: Awful Slowdown [Re: Case] #225079
03/05/04 07:23 PM
03/05/04 07:23 PM
Joined: May 2004
Posts: 3
F
FaithlessFemme Offline
stranger
FaithlessFemme  Offline
stranger
F

Joined: May 2004
Posts: 3
*sigh*

All I can do is try installing the game on my husbands machine, which is a lot newer than mine and see what result I get. It would be nice to not have to boot him out of his chair though...

When is the next patch due out? Any word?

Re: Awful Slowdown [Re: FaithlessFemme] #225080
03/05/04 07:32 PM
03/05/04 07:32 PM
Joined: May 2004
Posts: 6
C
Case Offline OP
stranger
Case  Offline OP
stranger
C

Joined: May 2004
Posts: 6
Heck. I've tried running this at 640-480 and I still get AWFUL slowdown.... It is just Really pixellated S-L-O-W-D-O-W-N.... Very annoying.... Where are all the options for dropping detail?! - Video options in game are a complete joke. Ohhh. Gamma! - Thanks. Configuration isnt much better. Resolution and Fog. Come on LARIAN. If you aren't going to give us a piece of software we can manually hobble, make sure it works with standard, current, off the shelf video card formats!!

Am going to install it on a crappy laptop tomorrow that just meets min spec. See if I can get it running on that.


LARIAN! - HELP!

Re: Awful Slowdown [Re: Case] #225081
04/05/04 10:10 AM
04/05/04 10:10 AM
Joined: May 2004
Posts: 17
zenyrrah Offline

stranger
zenyrrah  Offline

stranger

Joined: May 2004
Posts: 17
It was also very slow on my big machine, resolution 1200etc... but after restarting the game it was back to normal speed. I have the habit of playing continously, so the game never quits until finished. This can not be done with BeyDiv. On my laptop at work it runs smoothly in 1024. But here I quit after stop playing instead of putting the game on hold (pause) when I go for some recommended sleep

Re: Awful Slowdown [Re: zenyrrah] #225082
04/05/04 12:48 PM
04/05/04 12:48 PM
Joined: Nov 2003
Posts: 948
Plowking Offline
old hand
Plowking  Offline
old hand

Joined: Nov 2003
Posts: 948
This is all very odd.

First disable any anti-virus software and any thing else that runs in your taskbar you don't need before running the game.

My computer specs are so far below the min on the box it's a wonder the game even gets past the intro screen. But it does, and it runs PERFECTLY!!

The min specs on the box are totally out of whack with what the game can actually run on.

I have -

atlon 700
ram 512
geforce 2 32 mb card
and only a gig left on my hard drive.

I also recommend a program called RamIdle (found here http://www.tweaknow.com/ramidleLE.html)

It can keep your ram free in case there's some sort of memory leak thing going on with the software.

Maybe that all might make a difference!



Re: Awful Slowdown [Re: Plowking] #225083
05/05/04 08:49 AM
05/05/04 08:49 AM
Joined: May 2004
Posts: 6
C
Case Offline OP
stranger
Case  Offline OP
stranger
C

Joined: May 2004
Posts: 6
Many Thanks Plowking

I did alot of tinkering last night, but I downloaded and ran the apps you mentioned and Voila! - Runs much much better. I am putting it down to my New PC being very RAM inefficient.

PS - Even with Patch 1.32 Battlefield Dungeon 2 still empty of enemies! - Argh!!

Re: Awful Slowdown [Re: Case] #225084
05/05/04 09:46 AM
05/05/04 09:46 AM
Joined: Apr 2004
Posts: 15
Gent, Belgium
LukeSt Offline
stranger
LukeSt  Offline
stranger

Joined: Apr 2004
Posts: 15
Gent, Belgium
I read in another post the battlefield problem will definitely be fixed in the new patch, so keep your fingers crossed. I'm waiting to continue playing until then.

Re: Awful Slowdown [Re: LukeSt] #225085
06/05/04 03:16 PM
06/05/04 03:16 PM
Joined: May 2004
Posts: 12
Ayashin Offline
stranger
Ayashin  Offline
stranger

Joined: May 2004
Posts: 12
Hi everybody !

Even with RamIdle, there are still some slowdowns. When I first run the game, everything is ok during a few minutes but then it starts to get real slow.The strangest thing is when I save while there is a slowdown : the game speed goes back to normal after saving!! Unfortunately the slowdown comes back a few seconds later. My configuration is the following:

Laptop Compaq presario 920 EA
RAM 512 MB with 64 allocated to the video card (shared memory sucks !!)
Video card ATI radeon mobility
Processor AMD 2000 XP+

If anybody on the forum or in Larian has an idea, I would be eternally grateful.



Re: Awful Slowdown [Re: Ayashin] #225086
06/05/04 07:01 PM
06/05/04 07:01 PM
Joined: May 2004
Posts: 204
127.0.0.1
Neo987 Offline
enthusiast
Neo987  Offline
enthusiast

Joined: May 2004
Posts: 204
127.0.0.1
Ayashin: Your problem will probably be your processor and vid chipset. You're running on a laptop? Also, are you running RamIdle on a Win9x or XP OS?

Case and FaithlessFemme: Please post the following computer specs as follows and I'll try to help. If you have any extras, mention them. If you can't find all of the information, give me as much as you possibly can. I do this for a living

OS
CPU
RAM
Virtual Memory
HDD
Motherboard
Motherboard AGP
Power Supply
Sound Card
Video Card

Example from my box:
Windows XP Professional SP1
Intel Pentium 4 3.08GHz @ 800MHz FSB HT-Technology 1MB L2 Cache
PC2700 512MB DDR 400MHz
Min 588, Max 588
Western Digital 80GB, 5900 RPM, 8MB Cache, 7.2ms seek
Chaintech 9VJL5
x8
SoundBlaster Audigy 2 ZS
PNY GeForce 4 MX 440 64MB AGPx8


Re: Awful Slowdown [Re: Neo987] #225087
06/05/04 07:16 PM
06/05/04 07:16 PM
Joined: May 2004
Posts: 12
Ayashin Offline
stranger
Ayashin  Offline
stranger

Joined: May 2004
Posts: 12
I'm running ramidle on window xp pro. This could be a source of problems. I must say that I am quite frustrated not being able to play Beyond Divinity correctly, I have waited for this game so much. Anyway,Neo, how would you configure ramidle. I've left the defaults settings as is.



Re: Awful Slowdown [Re: Ayashin] #225088
06/05/04 07:19 PM
06/05/04 07:19 PM
Joined: May 2004
Posts: 204
127.0.0.1
Neo987 Offline
enthusiast
Neo987  Offline
enthusiast

Joined: May 2004
Posts: 204
127.0.0.1
The XP family does NOT like ram-boosting utilities, even if they were built for XP. Go ahead and post your stats as I requested from Case and Femme and we'll see if I can help you somehow. Also mention any other programs you have running in the background.

EDIT: To all three of you, please post your BD configuration settings too, please.

Last edited by Neo987; 06/05/04 07:22 PM.

Re: Awful Slowdown [Re: Neo987] #225089
06/05/04 09:01 PM
06/05/04 09:01 PM
Joined: May 2004
Posts: 12
Ayashin Offline
stranger
Ayashin  Offline
stranger

Joined: May 2004
Posts: 12
Here is my configuration :

Windows XP Pro SP1
Mobile AMD Athlon XP 2000+
RAM PC2100 512 MB of which 64 are allocated to the video card.
Virtual memory : min 1000 max 1000
Sound card : SoundMax Integrated Digital Audio
Video card : Radeon IGP 320 M 64 MB of shared memory

I hope somebody can find a way to solve the problem but I must say I have tried anything in order to find a solution. The whole thing is really starting to get on my nerves!!

Re: Awful Slowdown [Re: Ayashin] #225090
06/05/04 09:25 PM
06/05/04 09:25 PM
Joined: May 2004
Posts: 204
127.0.0.1
Neo987 Offline
enthusiast
Neo987  Offline
enthusiast

Joined: May 2004
Posts: 204
127.0.0.1
Quote:

Here is my configuration :

Windows XP Pro SP1
Mobile AMD Athlon XP 2000+
RAM PC2100 512 MB of which 64 are allocated to the video card.
Virtual memory : min 1000 max 1000
Sound card : SoundMax Integrated Digital Audio
Video card : Radeon IGP 320 M 64 MB of shared memory

I hope somebody can find a way to solve the problem but I must say I have tried anything in order to find a solution. The whole thing is really starting to get on my nerves!!




Well, here are some tips I can give you:

1) Set your virtual memory to 652/652 or 588/588. Your current size is way too big for your physical ram level. As a rule use this:
Virtual Memory max/min = 1.1GB - Physical Memory
Since you have shared memory, you may want to compensate for that, hence the 652/652.

2) Go to www.amd.com, see if you can find out how much L2 cache your processor has. Then go to www.freshdevices.com, download FreshUI, dig through the program till you find the L2 Cache setting, and input the value AMD supplied. I think my laptop's L2 level was either 256 or 512, I can't remember. (WARNING: The other settings in FreshUI are for power users. Do not change them if you don't know what you are doing or you could kill your system! However, if you know what you are doing you can massively improve your system.)

3) Make ABSOLUTELY SURE that you have completely updated drivers. Don't trust Windows Update or your laptop manufacturer's website. Go to the manufacturer, get your data sheet, and go out to each individual website and get the newest drivers.

4) Run Disk Defragmenter

5) Right-click on the desktop, go Properties>Appearence>Effects, and disable "Use the following transition effect for menus and tooltips" completely. Make sure "Use the following method to smooth the edges of screen fonts" is set to Standard.

6) I STRONGLY suggest you use the Windows Classic theme. All of the extra visual garbage XP piles on screws with games a lot.

7) In Display Properties, go Settings>Advanced>Troubleshoot and make sure the slider is all the way to the right. If it is, you may need to decrease it to increase speed, sacrificing some visual quality.

8) Go Start>Settings>Control Panel>System. In System go Advanced, and hit setting under Performance. Under Visual Effects choose "Adjust for best performance". You're going to lose some of the XP eye-candy, but which is more important to you?

You will have some problems with onboard video and sound, but changing these may help. Also, what configuration have you set for BD? By that I mean your resolution, FSAA, and fog settings.

EDIT: BTW, these settings will help ANY fullscreen/3D game on any system.

Last edited by Neo987; 06/05/04 09:30 PM.

Re: Awful Slowdown [Re: Neo987] #225091
07/05/04 02:24 PM
07/05/04 02:24 PM
Joined: May 2004
Posts: 12
Ayashin Offline
stranger
Ayashin  Offline
stranger

Joined: May 2004
Posts: 12
Hello again!

Well Neo, thanks for the info but sadly it didn't change a thing!! Maybe all I have to do is find a big nice tree and hang myself to it!! By the way, I already tried to change the settings of Beyond Divinity such as resolution, fog, etc... What is this smooth mode we can see in the configuration file?

Re: Awful Slowdown [Re: Case] #225092
24/05/04 06:09 PM
24/05/04 06:09 PM
Joined: May 2004
Posts: 1
N
necrodus Offline
stranger
necrodus  Offline
stranger
N

Joined: May 2004
Posts: 1
I know this answer comes a bit late but since I got BD a couple of days ago (release dates in Greece kinda late) hope you forgive me.
Anyway the problem you mention seems to appear to many Radeon equiped PCs either desktop or laptop - Mine is an ACER Aspire 2000 ( Mobility Radeon 9200 ) with XP Home- so I worked on it and I came up with this solution :
-changed the smooth option in config.lcl (or sth like that) to 0
-changed windows color depth to 16bit
-closed every running app and proccess except system ones plus the following :
taskswitch , task manager and soundman .

After all this stuff the game ran as expected , hope it works for any of you who experiences the same problems.


Moderated by  Dom_Larian, Larian_QA, Lynn, Macbeth 

Powered by UBB.threads™ PHP Forum Software 7.6.2