Divinity Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 4 1 2 3 4
EE Editor Problems/Bugs thread #580576
23/03/16 12:19 AM
23/03/16 12:19 AM
Joined: Jun 2013
Posts: 853
SniperHF Offline OP

old hand
SniperHF  Offline OP

old hand

Joined: Jun 2013
Posts: 853
So I've got the GOG version up and running and I immediately ran into a bunch of problems.

Bugs:
1. Whenever I launch even a blank slate standalone module, the main menu theme starts playing.

2. You can hear ocean sounds toward the edges of a blank map.

3. To get new global characters/objects to be recognized in "generate definitions" for the story editor I had to first make the object global on the side bar and save. Then completely close the editor and restart. Only then would the definitions generate.

I have not been able to reproduce this.

4. I had several crashes to desktop while selecting a number for the terrain size when creating a new one. This happened 4 times before I got it to work.



Request:
5. We need the Teleport command back. In the old version this was enabled even without developer mode. Making a mod without it would be impossible.



This one is more of a concern/question:
6. When first creating a new module I noticed I was unable to deselect the "Shared" dependency. Upon examination this dependency contains many of the D:OS system scripts you might want in a stand alone mod in the story editor. So that's good.

But a huge problem I can see this being is what if you need to modify those story script files? Because they are showing up as read only.

I was able to modify the meta.lsx file with a text editor and simply remove the dependency of "shared" and it seemed to work fine. The scripts went away and the editor behaved like the pre-ee editor did. Are there any consequences to this?

If there aren't can you just enable the ability to deselect shared as a dependency?

Thanks

Last edited by SniperHF; 23/03/16 02:01 AM.
Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580579
23/03/16 01:48 AM
23/03/16 01:48 AM
Joined: Aug 2015
Posts: 308
Quebec, Canada
N
norD Offline
enthusiast
norD  Offline
enthusiast
N

Joined: Aug 2015
Posts: 308
Quebec, Canada
Hi SniperHF, thanks for bringing bugs up.
I'll forward that topic to the devs.

I also made it a sticky.

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580596
23/03/16 08:27 AM
23/03/16 08:27 AM
Joined: Jun 2014
Posts: 8
Argentina
RiiJ Offline
stranger
RiiJ  Offline
stranger

Joined: Jun 2014
Posts: 8
Argentina
My contribution:

Originally Posted By: SniperHF

Bugs:
1. Whenever I launch even a blank slate standalone module, the main menu theme starts playing.

2. You can hear ocean sounds toward the edges of a blank map.

I manage to inmediatly stop those two issues by switching to Game from Editor Mode and backwards. But when loading or reloading any module or level, no matter if the editor was restarted or not, the music and wave sounds returns.

Quote:
3. To get new global characters/objects to be recognized in "generate definitions" for the story editor I had to first make the object global on the side bar and save. Then completely close the editor and restart. Only then would the definitions generate.

I have not been able to reproduce this.

Yep, shit happens, everytime.

Quote:
4. I had several crashes to desktop while selecting a number for the terrain size when creating a new one. This happened 4 times before I got it to work.

Me too. Only that instead of inevitable CTD I was prompted to continue (with no further drama) or quit. Finally realized that the bug occurs when neither the Width or Height input boxes were empty: any number on it, no problem; no number at all, CTD problem.



Must add that while closing the editor it always (at least that I can remember) crashes, although with apparently no issues when restarted.



Excuse my english, although Obama is currently visiting my country, it still isn't my primary language smile

Last edited by RiiJ; 23/03/16 08:28 AM.
Re: EE Editor Problems/Bugs thread [Re: RiiJ] #580609
23/03/16 01:15 PM
23/03/16 01:15 PM
Joined: Dec 2013
Posts: 851
Windemere Offline

old hand
Windemere  Offline

old hand

Joined: Dec 2013
Posts: 851
Originally Posted By: RiiJ
Must add that while closing the editor it always (at least that I can remember) crashes, although with apparently no issues when restarted.


I'm not seeing that, though I didn't do a whole lot other than play around with a new terrain.


Shadow Over Moonglow - Standalone campaign (WIP)

The Noisy Crypt
(also on Nexus)

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580615
23/03/16 05:02 PM
23/03/16 05:02 PM
Joined: Mar 2016
Posts: 485
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 485
Belgium
I've also encountered a pretty annoying bug with undo after adding a new item/character:
1) open resources
2) select Animals_Rabbit_A (or anything else)
3) click on the "+" button at the top to add an item
4) click somewhere on the terrain
5) press ctrl-z to immediately undo adding the item

Result:
You get a pop-up dialog stating "The object is locked by source control!". After clicking the "OK" button, the object gets moved to the bottom left corner of the map, and cannot be deleted/edited anymore.

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580616
23/03/16 05:11 PM
23/03/16 05:11 PM
Joined: Mar 2016
Posts: 485
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 485
Belgium
Originally Posted By: SniperHF

This one is more of a concern/question:
6. When first creating a new module I noticed I was unable to deselect the "Shared" dependency. Upon examination this dependency contains many of the D:OS system scripts you might want in a stand alone mod in the story editor. So that's good.

But a huge problem I can see this being is what if you need to modify those story script files? Because they are showing up as read only.

You can right-click these entries and select "Copy to my mod...". Afterwards you can edit these local copies.

Re: EE Editor Problems/Bugs thread [Re: Tinkerer] #580617
23/03/16 05:32 PM
23/03/16 05:32 PM
Joined: Jun 2013
Posts: 853
SniperHF Offline OP

old hand
SniperHF  Offline OP

old hand

Joined: Jun 2013
Posts: 853
Originally Posted By: Tinkerer


You can right-click these entries and select "Copy to my mod...". Afterwards you can edit these local copies.


Cool, seems to work. Though when I do it this causes random Unhanded exceptions

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580672
24/03/16 03:14 PM
24/03/16 03:14 PM
Joined: Oct 2015
Posts: 6
K
Kiril9 Offline
stranger
Kiril9  Offline
stranger
K

Joined: Oct 2015
Posts: 6
Thrilled that the editor is finally out.
However, when I try to open it, it crashes immideately. (App stopped working) Win10.

Any clues?

Re: EE Editor Problems/Bugs thread [Re: Kiril9] #580675
24/03/16 04:28 PM
24/03/16 04:28 PM
Joined: Sep 2014
Posts: 55
Cadmus88 Offline
journeyman
Cadmus88  Offline
journeyman

Joined: Sep 2014
Posts: 55
Can you check Config.xml file in folder where engine is installed.

Your paths to data need to look like something like

<EditorDataPath>D:\SteamLibrary\steamapps\common\Divinity Original Sin Enhanced Edition\Data\Editor\</EditorDataPath>
<DataPath>D:\SteamLibrary\steamapps\common\Divinity Original Sin Enhanced Edition\Data\</DataPath>

Incorrect paths will lead to a crash.

My only guess for now. Editor may just don't work with Windows 10 or something

Last edited by Cadmus88; 24/03/16 04:31 PM.
Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580677
24/03/16 06:06 PM
24/03/16 06:06 PM
Joined: Jun 2013
Posts: 853
SniperHF Offline OP

old hand
SniperHF  Offline OP

old hand

Joined: Jun 2013
Posts: 853
Few more bugs for the pile:

1. Sub Goals are not persistent.

I cannot move a goal file under the __Start goal (or any other for that matter) and have it stay there. I can move a goal underneath and it will stay there. But after closing the editor it reverts back to being at the top level. Only the default scripts stay in place.

EDIT: Just an update on this one, this is actually a much bigger problem than I thought. The way the game loads goal files it makes all sorts of things break when certain things aren't under __Start.

I was able to make a goal stay under __Start only by typing in manually TargetEdge "MyTestGoal" in the file through a text editor.



2. Sometimes after generating definitions/building story the camera ends up in weird places like upside down underneath the terrain.


3. The mouse cursor gets stuck as the game cursor sometimes when switching between editor/game mode.



Question:

Can the editor be made to remember your "auto load multiselect" setting on the sidebar?

Last edited by SniperHF; 24/03/16 08:26 PM.
Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580684
24/03/16 09:04 PM
24/03/16 09:04 PM
Joined: Mar 2016
Posts: 485
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 485
Belgium
Originally Posted By: SniperHF
Few more bugs for the pile:

1. Sub Goals are not persistent.

I cannot move a goal file under the __Start goal (or any other for that matter) and have it stay there. I can move a goal underneath and it will stay there. But after closing the editor it reverts back to being at the top level. Only the default scripts stay in place.

That's (also) because the __Start goals is part of the read-only "Shared" package. If you copy __Start to your mod, you can add subgoals to it.

Quote:

2. Sometimes after generating definitions/building story the camera ends up in weird places like upside down underneath the terrain.

I mostly get this problem after exiting game mode for some reason.

Re: EE Editor Problems/Bugs thread [Re: Tinkerer] #580685
24/03/16 09:27 PM
24/03/16 09:27 PM
Joined: Jun 2013
Posts: 853
SniperHF Offline OP

old hand
SniperHF  Offline OP

old hand

Joined: Jun 2013
Posts: 853
Originally Posted By: Tinkerer

That's (also) because the __Start goals is part of the read-only "Shared" package. If you copy __Start to your mod, you can add subgoals to it.


I'm having that problem with it copied.

Last edited by SniperHF; 24/03/16 09:27 PM.
Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580694
25/03/16 08:01 AM
25/03/16 08:01 AM
Joined: Sep 2014
Posts: 55
Cadmus88 Offline
journeyman
Cadmus88  Offline
journeyman

Joined: Sep 2014
Posts: 55
You always need to close StoryEditor after you docked one goal to another. Then open the parent goal with text editor e.g Sublime Text or Notepad and add

Code:
TargetEdge "ChildGoalName"


at the bottom of the file.

Then you save and reopen StoryEditor, the child goal will be docked to its parent.

Cheers!

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580695
25/03/16 08:21 AM
25/03/16 08:21 AM
Joined: Mar 2016
Posts: 485
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 485
Belgium
Originally Posted By: SniperHF
Originally Posted By: Tinkerer

That's (also) because the __Start goals is part of the read-only "Shared" package. If you copy __Start to your mod, you can add subgoals to it.


I'm having that problem with it copied.

That definitely sounds like a bug, because copying the goal to your own mod is the solution I got from a Larian scripter himself (when using the old editor, but I assume that shouldn't have changed).

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580698
25/03/16 01:08 PM
25/03/16 01:08 PM
Joined: Oct 2008
Posts: 62
A
ALF Offline
journeyman
ALF  Offline
journeyman
A

Joined: Oct 2008
Posts: 62
That is a known bug indeed. Instead of modifying __Start, the recommended way to go about this is:

1. Create a new goal <your_mod>Start
2. Add the following text in the KB section:
IF
GameEventSet("GAMEEVENT_GameStarted")
THEN
GoalCompleted;
3. Parent your mod's goals to that goal instead of the Shared one

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580746
27/03/16 01:47 AM
27/03/16 01:47 AM
Joined: Jun 2013
Posts: 853
SniperHF Offline OP

old hand
SniperHF  Offline OP

old hand

Joined: Jun 2013
Posts: 853
More stuff for the pile:

1.
This is an old problem but still present in the EE Editor. The icon previews do not load in the editor without extracting data from the icons.pak and placing them in the folder: Data\Public\Shared\Assets\Textures\Icons

The files are pretty darn small so perhaps you could just include pre-extracted versions in that location?
http://i.imgur.com/vFTIvfr.png?1

Anything like that which makes the editor more usable out of the box is a good thing.


2. When placing objects, if you immediately hit undo you get a message that says "Blocked by source control".

The object does disappear but it moves to the 0 location of the level. It will disappear upon restart however and cause no problems.


Improvement suggestions:
1. The line of sight fade out of NPCs while in editor mode is quite annoying. The old version didn't do this.


2. Include Alignment.lsx
Data\Mods\YOUR MOD\Story\Alignments

Along the same lines of usability, it would probably be a good idea to automatically make a copy of the main alignment folder/file everytime a new mod is created. Anyone interested in customizing would figure it out but a newbie will have a much easier time if it's already there.

Last edited by SniperHF; 27/03/16 01:49 AM.
Re: EE Editor Problems/Bugs thread [Re: ALF] #580748
27/03/16 04:43 AM
27/03/16 04:43 AM
Joined: Jun 2014
Posts: 8
Argentina
RiiJ Offline
stranger
RiiJ  Offline
stranger

Joined: Jun 2014
Posts: 8
Argentina
Originally Posted By: ALF

1. Create a new goal <your_mod>Start
2. Add the following text in the KB section:
IF
GameEventSet("GAMEEVENT_GameStarted")
THEN
GoalCompleted;

Mmm, isnt an entry missing here?

THEN
InitStory();
GoalCompleted;

Think its necessary for a safe story initialization, am I wrong?

Re: EE Editor Problems/Bugs thread [Re: RiiJ] #580749
27/03/16 08:57 AM
27/03/16 08:57 AM
Joined: Sep 2014
Posts: 55
Cadmus88 Offline
journeyman
Cadmus88  Offline
journeyman

Joined: Sep 2014
Posts: 55
Originally Posted By: RiiJ
Originally Posted By: ALF

1. Create a new goal <your_mod>Start
2. Add the following text in the KB section:
IF
GameEventSet("GAMEEVENT_GameStarted")
THEN
GoalCompleted;

Mmm, isnt an entry missing here?

THEN
InitStory();
GoalCompleted;

Think its necessary for a safe story initialization, am I wrong?


No, it's not needed. If you use dependency on Shared in your mod (which is by default, unless you changed meta yourself) you already have __Start goal from Shared, which contains it, and it will be executed when it's needed.

Your ModStart goal purpose is, as above ALF said is to dock your mod goals in it and execute them in correct order (when game started, that's why there is a game started event)

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580764
27/03/16 11:46 PM
27/03/16 11:46 PM
Joined: Jun 2014
Posts: 8
Argentina
RiiJ Offline
stranger
RiiJ  Offline
stranger

Joined: Jun 2014
Posts: 8
Argentina
Originally Posted By: Cadmus
If you use dependency on Shared in your mod (which is by default, unless you changed meta yourself) you already have __Start goal from Shared, which contains it, and it will be executed when it's needed.


Ah, of course! Didnt realize it was for a mod with Shared dependency, blame my apparently poor reading comprehension :S.
I was thinking in a __Start builded from scratch effectively changing Meta.lsx like you said. From practicing with the classic editor, I find is easy to me that way, building, collecting or unpacking one goal at the time. Maybe I should "modernize" my working plan :P

Thanks!

Re: EE Editor Problems/Bugs thread [Re: SniperHF] #580899
31/03/16 06:01 PM
31/03/16 06:01 PM
Joined: Sep 2015
Posts: 436
A
Abraxas* Offline
addict
Abraxas*  Offline
addict
A

Joined: Sep 2015
Posts: 436
Some initial experiences with the Editor (Steam):

1. The problem with the Editor crashing on Exit as Riij described occurs for me too (almost every time).
2. Crash on changing module.
3. I've created a new module with dependencies on Main and Shared (and datapacks Main and Shared) to mod the main campaign. But the possibilities to make changes seem to be quite limited: I can't save changes on existing characters and objects of the main campaign due to missing developer rights. So attaching new char scripts, for example, is not possible. I don't know another way to do that; maybe adding new scripts to my Mod via Ressource Manager, catching the script ID and adding an entry to the lsb/lsx files in Mods\Main\Globals\[Level]\Characters\ ? And adding an entry to the characters.lsb file in Data\Public\Shared\RootTemplates\ when I want to add scripts to all characters with a certain template?

Adding and saving new characters and objects is possible.

Currently I have no idea how to take full advantage from the Editor at modding the main campaign.

Page 1 of 4 1 2 3 4

Powered by UBB.threads™ PHP Forum Software 7.6.2