(copied from Steam community forum)
POSSIBLE SOLUTION TO ALL THE GAME'S CRASHING OR NOT STARTING ISSUES ON WINDOWS7
If you're running Windows 7, launch the game from C:\Program Files (x86)\Steam\steamapps\common\divinity2_dev_cut\bin thhrough Divinity2.exe IN COMPATIBILITY MODE WITH WINDOWS 7! Choose the file, select properties, tick Comatibility mode with Windows 7, Apply, Ok, proceed to launch the game.

IMPORTANT: CLEAN UP THE GRAPHIC OPTIONS FILE! AND TURN THE VALUES OF 'LOCKSTEPMODE" "USEMULTICORE" "FPSCAP" TO 0! IF THEY'RE ALL TO 0 MY GAME RUNS FINE and I can enjoy maxed graphic settings in the meantime at once.
it's in
C:\Users\Acocieto\AppData\Local\Divinity 2\Profile , graphicoptions.xml (launch in notepad)
Default is like "<root> <pointer> <GraphicSettings [options here]> </root> <options>" 1. Delete all the spaces outside of the [options]. All of them shall be gone! Make sure there is absolutely nothins inbetween "><" NOTHING!
"<root><pointer><GraphicSettings[options]/></pointer></root>" - VERY GOOD. Make it so!
My file, after succesfully launching the game (after I did two above steps, launched and worked!) is like this:
"<root>
<pointer><Gra[options]/>
</pointer>
</root>
"
This is my file of the game after it launched succesfully.

My whole graphicoptions.xml file content (feel free to copy this and paste it into your graphicoptions xml file, completely replacing the content):

<root>
<pointer><GraphicSettings Fullscreen="0" RenderMethod="1" ScreenWidth="1920"

ScreenHeight="1080" RenderRefraction="0" DynamicReflections="0" ShadowQuality="2"

RenderShadows="0" TextureQuality="0" AnisotropicSamples="0" UseHDR="0" UseVSync="1"

AnisoType="2" AnimationTimeSlicing="0" ShadowTimeSlicing="0" QualityModeIndex="5"

StaticAssetHighQuality="1" RenderLightShafts="0" RenderDOF="0" VegetationQualityLevel="2"

DynamicAssetQualityIndex="1" DynamicAssetQualityMultiplier="0" TreeQualityLevel="2"

TreeQualityMultiplier="2" UseScreenSpaceAA="0" UseMultiCore="0" LockStepMode="0"

FPSCap="0" DynamicLightQuality="0"/>
</pointer>
</root>

It has the lowest graphic settings made, but IT WORKS! REALLY DOES. After you launch the game and start your playthrough you may prefer to increase the graphic settings, but leave the three values I mentioned above on 0!
Compatibility mode also did it's good! I can quit the game, start it again and load times are fast and noting crashes!
I boosted my graphic settings so the game looks better and shows everything.

So, run the game directly through the Divinity.exe in the game's folder (listed above) in compatibility mode with Windows 7 (or yours Operating System if it's different) (as said above, set into such option through file properties in Compatibility tab)
and just edit your graphicoptions xml file (in directory lsited above), deleting your content and pasting mine in (also listed above, under "my whole graphicoptions xml file content").

I fixed the issue of ingame videos playing upside-down by downloading codec packs for Windows 7 (I downloaded like 3 different and installed them all subsequently) and I experience no issues in the game while watching skill previews or cutscenes or intro logos - everything works.

I think these are the ones I downloaded (note, that your system may require different ones)
http://www.free-codecs.com/download/advanced_codecs.htm
http://www.windows7codecs.com/
http://www.free-codecs.com/codec_pack_all_in_1_download.htm

[final edit]
I have launched my game, in settings boosted (maxed) the graphic setting and the game still works!
I have left the setting valuess of FPScap, UseMulticore and LockStepMode on 0. The game runs very well and gives no errors.


Edited by kamboyah (07/02/17 07:11 PM)